Skip to main content

Argo Community High School

Cloud Service Status

323 Copier-Offset Stapler

minor icon Minor
ACHS Copiers icon
ACHS Copiers
Investigating icon Investigating

Incident timeline

minor icon Minor

Investigating - Copier Works, the staples can be offset from time to time.

Affected:
ACHS Copiers icon
ACHS Copiers